performance degradation

Incident Report for ThredUp

Resolved

The issue has been resolved. We are actively monitoring the status
Posted May 21, 2021 - 22:24 UTC

Investigating

We observe performance degradation across the services. Investigating the root cause
Posted May 21, 2021 - 22:18 UTC
This incident affected: Add to Cart.