Intermittent site issues
Incident Report for ThredUP
Resolved
This incident has been resolved.
Posted Feb 21, 2020 - 21:49 UTC
Identified
We see intermittent issues with a website that are related to a high database load. Engineering team is working on a fix
Posted Feb 21, 2020 - 21:32 UTC
This incident affected: thredUP.com Desktop & Mobile Web.